Results 1 to 9 of 9
  1. #1
    Harmless Inactive Member
    muscken's Avatar
    Join Date
    Dec 2011
    Posts
    5
    Downloads
    0
    Uploads
    0

    my keyboard doesn't work

    Hi guys, i'm new so be patient please
    i've bought yesterday ma second amiga 500.
    it works fine except for the keyboard.
    i can play games, use mouse or joystick but keyboard doesn't response.
    one strange thing is that caps lock light is always turned on and there aren't ways to turn it off.
    what could be? is there a way to solve the problem?
    thanks a lot!!!

  2. #2
    Retro Addict Administrator
    My location

    Burger Time Champion, Sonic Champion Harrison's Avatar
    Join Date
    Dec 2002
    Location
    UK
    Posts
    15,597
    Blog Entries
    1
    Downloads
    6
    Uploads
    14
    The first thing to check is that it is connected to the motherboard correctly. To do this you will need to open it up. This isn't hard as it just involves removing the screws along the front edge ender the Amiga and a couple down each side underneath. Once done the case should come apart and the keyboard can be lifted free. The keyboard is plugged into the motherboard by some wires at the back in the middle. Try unplugging it and then plugging it back in correctly and see if this fixes the problem.

    If not then it could be a fault with either the keyboard itself or one of the chips on the motherboard.

    If you haven't played a classic game in years, it's never too late to start!


  3. #3
    Harmless Inactive Member
    muscken's Avatar
    Join Date
    Dec 2011
    Posts
    5
    Downloads
    0
    Uploads
    0
    thanks a lot, tomorrow i will try.
    thanks

  4. #4
    Harmless Inactive Member
    muscken's Avatar
    Join Date
    Dec 2011
    Posts
    5
    Downloads
    0
    Uploads
    0
    i've removed the cover, I tried to remove and replace the keyboard pin from the board but nothing has changed.
    here there are some photos, maybe they will be helpful. what is that flying metal cable under the keyboard?
    other ideas / attempts?
    thanks a lot!

    http://imageshack.us/photo/my-images/502/p1010207s.jpg/
    http://imageshack.us/photo/my-images/546/p1010208x.jpg/
    http://imageshack.us/photo/my-images/841/p1010209t.jpg/
    Last edited by Teho; 6th December 2011 at 19:53.

  5. #5
    Retro Addict Administrator
    My location

    Burger Time Champion, Sonic Champion Harrison's Avatar
    Join Date
    Dec 2002
    Location
    UK
    Posts
    15,597
    Blog Entries
    1
    Downloads
    6
    Uploads
    14
    I don't know what that metal cable is shown in your last image. I don't think I have that in any of my A500s.

    Does the caps lock led blink at all when you switch the system on? If so how many times?

    • One blink: Keyboard ROM check failed.
    • Two blinks: Keyboard RAM check failed.
    • Three blinks: Watch dog timer failure.
    • Four blinks: A short between two lines or the special control keys.


    Don't worry if it flashes once as this is normal when any Amiga boots. The blinks will happen on a loop so you will know.

    It is isn't blinking then we can rule that out.

    The next thing you can try is to see if the CIA chips are faulty on the motherboard. There are 2 of these chips that control the keyboard and mouse. To test faults you can swap them over, as this will then show the keyboard working and the mouse not working, if that is the cause. The two CIA's are both 40-pin chips that are marked CIA ODD and CIA EVEN. Simply swap them over, making sure that you have placed them in the right way, then power the Amiga back up and see what happens.

    If you haven't played a classic game in years, it's never too late to start!


  6. #6
    Harmless Inactive Member
    muscken's Avatar
    Join Date
    Dec 2011
    Posts
    5
    Downloads
    0
    Uploads
    0
    hi harrison, thanks...the caps lock light doesn't blink, it's always on (like the first picture that i've posted).
    where are this two chips? on the mainboard?

    p.s. in another forum somebody told me that metal cable is grounding...

    ---------- Post added at 10:02 ---------- Previous post was at 09:14 ----------

    i've found this photo
    http://www.flickr.com/photos/lu6fpj/2745203804/
    where are the two chips? the two near keyboard connector?
    thanks

  7. #7
    Retro Addict Administrator
    My location

    Burger Time Champion, Sonic Champion Harrison's Avatar
    Join Date
    Dec 2002
    Location
    UK
    Posts
    15,597
    Blog Entries
    1
    Downloads
    6
    Uploads
    14
    That picture looks like a very early revision. All the ones I've seen have green motherboards with much clearer writing on the board labelling the sockets.

    On that picture the 2 CIA chips are in the middle towards the back of the board. The CIA ODD A chip is directly to the left of the keyboard cable header, and the CIA EVEN B chip is the one directly below the floppy drive cable and to the right of the floppy drive power cable header. See them now?

    Here is a later (newer) a500 motherboard:
    http://www.tk-webart.de/images/amiga...oard-Rev8a.jpg

    In this second picture you can clearly see the 2 CIA labelled sockets. This images has the ODD CIA chip removed from its socket.

    If you haven't played a classic game in years, it's never too late to start!


  8. #8
    Harmless Inactive Member
    muscken's Avatar
    Join Date
    Dec 2011
    Posts
    5
    Downloads
    0
    Uploads
    0
    maybe in these weeks i'll receive another a500.
    i wanna try to switch the keyboards. its a problem if they are different a500 version?
    thanks

  9. #9
    Retro Addict Administrator
    My location

    Burger Time Champion, Sonic Champion Harrison's Avatar
    Join Date
    Dec 2002
    Location
    UK
    Posts
    15,597
    Blog Entries
    1
    Downloads
    6
    Uploads
    14
    Shouldn't be. As far as I know all A500 keyboards were the same.

    If you haven't played a classic game in years, it's never too late to start!


Similar Threads

  1. A500+ Keyboard problems
    By Stephen Coates in forum Hardware
    Replies: 4
    Last Post: 1st April 2010, 19:01
  2. Best PC keyboard adapteR?
    By StuKeith in forum Hardware
    Replies: 2
    Last Post: 3rd September 2008, 15:02
  3. Ultimate keyboard
    By AlexJ in forum PC - Windows, Linux, Mac
    Replies: 11
    Last Post: 13th June 2007, 15:25

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Copyright classicamiga.com