Unless you're gonna install AmigaOS 3.5+, you'll not need 3.1 ROMs. AmigaOS 3.1 runs fine with 3.0 ROMs too.