View Full Version : WHDLoad under UAE...

6th April 2011, 15:17
Hi everybody,

Perhaps someone can help me with a conundrum.

My WHDLoad.key works fine on my real Amigas, but under UAE (E-UAE or WinUAE) it crashes horribly when loading a game. Remove the keyfile, WHDLoad works perfectly. Put the keyfile back in, BOOM.

Has anyone else ever seen this or is it just some weird thing for me?

6th April 2011, 15:40
That behaviour normally happens with WHDLoad thinks the key is a pirated copy or not genuine. Either it will just shut itself down and go back to Workbench, or you get a black screen.

I'm not sure why your key works on a real system and not under emulation though. Where are you placing the key in the OS? I normally put mine in the S: directory and haven't had any problems running it in WinUAE or on real hardware.

6th April 2011, 16:01
I put mine in all the usual places, RAM:, S:, PROGDIR:, everything.

It doesn't quite cleanly, though, it crashes horribly in an emulated equivalent of the screamin' heebie-jeebies.

Tried it on different UAE set-ups, and everything.

It's a genuine key, too - I bought it years ago myself....

6th April 2011, 16:01
I also got a "valid" key for WHDLoad, and it works as before, only difference, is that it's faster to load the game.
Strange that it works on real Amiga. I found in last times that UAE is getting better and better, all the errors i found in emulation i also got in Real Amiga, and vice-versa.
Try to ask a new key...

6th April 2011, 16:14
Are your keyfiles also 888 bytes long?
Obviously I can't ask someone for their keyfile as you don't I've really got a key, but could I send someone (trusted!) who already has a registered WHDLoad setup my key and see if it works for them please?

6th April 2011, 16:17
Dont know if they are 888bytes long...i could check that.

I could test your key if you want.

6th April 2011, 16:51
I just checked my own key and it is also 888 bytes long, so that confirms that.

I would also be more than happy to test your key using WinUAE if you needed.

7th April 2011, 12:34
Just for information:
Dave (Harrison) has kindly tested my key and it works fine. It's just on all my machines it doesn't.
Really confused!

7th April 2011, 14:34
As suggested in a PM to you, if you are running Windows Vista or Windows 7, they come with Direct X 10 and/or 11. However WinUAE does require DirectX 9.0c to function fully and this version of DirectX needs to be manually installed alongside the newer versions in these OSs.

7th April 2011, 15:52
Good idea, but not in this case I'm afraid. WinUAE runs just fine, the problem is very much an emulatED error, not an emulatOR error.

I've run it under two Windows 7 machines, an AmigaOS 4 machine and a Morphos 2 machine. Same happens on all.

7th April 2011, 17:03
Are you using the same Workbench setup on each? If so that is probably the issue.

Maybe it would be worth downloading one of the current ClassicWB versions and setting it up as a fresh install, adding your key to the S directory and seeing if Bloodwych (included by default with ClassicWB) will run. If that works then add and try a couple of other games. That will prove if it is something specific to your existing setups.

11th April 2011, 10:15
I tried ClassicWB!

It still didn't work! Same problem exactly!

Any chance I can try your keyfile please? You've got my key so you know I've registered it... but I'll understand if you don't want to send it me for fear of me distributing it.

I really don't understand what could be wrong. The only variable I can think of is my WB3.0 ADF file - maybe it's dodgy. I'll try with a WB3.1 one if I can find one...

11th April 2011, 11:21
Spirantho, as i remember, there are 2 folders where you can put the key, with me, the first folder were i placed the key didn't work, only in second folder... did you try the 2 options?

11th April 2011, 14:34
I tried (almost!) everywhere.
It's not that the registration key doesn't work - it does, the box comes up with my name and everything - it's that the whole emulated Amiga crashes whenever I use my key. Remove the key - works fine. Put the key in S:, RAM:, whatever: crashes the Amiga.

I think it just doesn't like me. :)

11th April 2011, 14:47
and it works fine on real amiga?
did you try to put your real Amiga HD on your PC with Winuae?

11th April 2011, 17:19
What I will do for you tomorrow is create a small working HDF for you to test out, using ClassicWB, with a registered keyfile and a couple of games.

12th April 2011, 11:16
I'm just installing ClassicWB UAE now using brand new Workbench 3.1 disks I got when I upgraded my A1500 the other week.

Watch this space...!

12th April 2011, 11:40

It still crashes. No keyfile, works fine. Put in my keyfile... screen goes black, junk appears on screen briefly, then I get this:


Click on "Make Coredump" and it gives a software failure (instead of actually creating a dumpfile in T:, which is where I believe it goes).

This is a completely new UAE install of Classic WB (UAE). The WB disks are brand new OS3.1 disks. The ClassicWB is a WB3.1 upgraded installation (using the normal ClassicWB installer). The keyfile is the only change.

Doing a no startup-sequence boot just gives me the usual result: no keyfile, works. With keyfile, black screen and garbage.


12th April 2011, 16:32
Very strange. And even stranger that your keyfile worked perfectly for me when I tried it.

One question. How old is your keyfile? How long ago did you register it? Some older keyfiles get blacklisted in newer WHDLoad releases, although that wouldn't answer why it worked for me.

Maybe you could email the WHDLoad team member who deals with the keyfiles and see if he can send you a new one. Worth a shot.

12th April 2011, 16:43
There's no reason why it should be blacklisted as far as I know.. and even if it were, surely it'd just say "This is an unregistered version", not crash horribly.
The keyfile is quite old, though, it's true.
I'll have to see if I can get a new keyfile, I guess. Very confusing, though - especially, as you say, given it works for you!

12th April 2011, 16:48
The WHDLoad team don't actually tell you when it detects a blacklisted key. The WHDLoad team are more sneaky than that. Instead if it thinks the key is suspect strange things will start happening, like games crashing, loading to black screens, some in-game graphics looking corrupt. This is why I wonder if you key has somehow becoming blacklisted.