View Full Version : An odd HDD issue

6th August 2008, 10:01
The other day I was RARing up some large files on my XP install and the PC hung after completing. Nothing could be ddone so I had to hit reset.

When it started up again it wouldn't boot - giving the non system disk error asking me to insert a boot disk.

Fiddling about unplugging the two HDDs and swapping them about and into different SATA sockets on the motherboard eventually let me boot to XP, and then eventually boot to vista too.

But then it did it again, so I went to BIOS and fiddled with the booting priorites. Now it all seems to be working OK again. I'm a bit worried this may hapend again (it did this once before AGES ago when I was just on XP, but after leaving it switched off for a while it was fine).

Anyone else had a similar thing and got any ideas? I'm happy now it's working, but wouldn't want it to happen again - especially if say I'm not here to fix it and the wife wants to be using the computer.

One thing - I'm using the SATA cables that came with the A8n-e and they do seem rather loose and wobbly, coming off the mobo easily. Is this expected with bogg-o standard cables?

6th August 2008, 16:24
All SATA cables feel a bit like they will come off from their connectors quite easily so that shouldn't be anything to worry about. Although new SATA cables don't cost much if you really wanted to replace them.

I had a similar problem with my Athlon 64 system last year. It was working fine one night, but when I went to start it up the next day it didn't find the IDE or SATA HDs and the non system disk was displayed. It would only boot up if I put the original Windows XP install disc in the drive. Very strange. I then checked the BIOS and somehow the settings for the HD boot sequence order had changed. My boot HD at the time was IDE, with extra SATA drives for data and it had changed it to SATA then CD then IDE so it wasn't finding it. I switched the order back, saved, and it worked again.

However I later had another HD issue. The IDE boot drive was sometimes creating read errors when the OS was booting so I thought it best to just replace it with an SATA drive. I had a spare Maxtor SATA drive so formatted that and tried to install XP onto it. It got as far as the point where all the files are setup on the HD and it asks you to remove the CD and reboot the system. But on rebooting the system it couldn't find any HDs or OSs. After much trial and error and googling I discovered there is a conflict between nForce4 based motherboard chipsets and Maxtor SATA HDs. So I bought a new 500GB Seagate SATA HD and that worked perfectly. Installed XP without any problems and it has been working perfectly ever since.

First thing to always check in such situations is the HD and if it is still physically OK. There are tools on the HiRens boot CD (downloadable from The Vault) for all makes of HD and you should be able to use that from within Windows to check the condition of the HD. You might find you have some bad sectors on the disk. If that is the case then the best solution is to replace it. However most of the tools can successfully flag any bad sectors and mark them out of use, so that when you then format the HD it is fully working again. I did this with the IDE HD I took out of that system and it found a few bad sectors and flagged them as out of use. I've since continued to use the HD for a Linux box and it has continued to work OK.

So I would do the following if you are worried.

1, Check the boot sequence in the BIOS. It can sometimes change around for no reason and prevent the HD from booting.
2, Run a disk checking tool (CMD and Windows tools exist from all HD makers)
3, If it finds any bad sectors let the tool sort them out, then format the drive to reuse it again.
4, If you do have bad sectors or the tool throws up other errors then buy a new boot drive and use the old one as a spare drive for something like downloads, music etc...
5, Check the PSU and IDE/SATA cables - I had a system suddenly stop booting the HD and not even seeing the drive in the BIOS. I replaced the cable and it then worked fine again. PSU could also be on its way out and not feeding enough power, but that should exhibit some obvious behaviour when you run an intensive disk checking tool.