View Full Version : Firefox 3 invalid security certificate problem

25th July 2008, 14:08
Everyone who has updated to Firefox 3 will very quickly encounter an error message that is not easy to instantly work out how to fix.

When visiting many commonly used sites such as Google, Yahoo, your ISP etc you might be presented with an error screen instead of the site, announcing that the site is using an invalid security certificate, and Firefox 3 will not allow you to bypass it to actually get to the site. Quite mad!

I initially encountered this problem with many sites I use daily. The first was the Firefox Add-Ons site itself. Others included the 1and1 admin login, Google and a few more.

To access such sites again you need to add then to the Certificate Manager exceptions list. To do this you have to go to Tools/Options and then to the Advanced Tab and click on View Certificates. Then navigate to the Servers tab and scroll down through the list of Certificate names until you find the site you cannot access. Select this and then click the Add Exception... button. Then add the server location (the full url of the site/page you are trying to access) and click Get Certificate. It will show details of the Certificate Status and the problem it has with it. Make sure Permanently store this exception is ticked, and then click the Confirm Security Exception to add it to the list.

You should now be able to access the site without the error or further problems.

25th July 2008, 14:11
Not had any problems with FF3 and certificates yet. Theres still time though.

10th December 2008, 15:39
Maybe this has already been fixed in a Firefox3 update, but I have never seen such a problem with my Firefox3 install.

10th December 2008, 15:45
I still get it with every site I visit that uses an SHTTP:// based URL. It instantly refuses to load the page until I've manually gone into the certificate manager and added an exception for the site concerned. Is quite annoying. I've looked through every FF3 option to see if it can be disabled but not found a way yet.

10th December 2008, 16:18
Still can't understand why you get this problem.
When you go Tools/Options and click on the Advanced do you have Select one automatically or Ask me every time ticked in the When a server requests my personal certificate. Also when you click the Validation button what settings do you have?

10th December 2008, 16:41
OK. Yes, I have "Select one automatically" selected, and in the Validation window I have Use the OCSP to confirm the current validity of the certificate ticked, and inside of that the Validate a certificate if it specifies an OCSP server selected.

10th December 2008, 16:48
Have you tried the "ask me every time" option (Thats the one that I use) in the certificates?

10th December 2008, 16:49
Yes, but it makes no difference. It doesn't ask me. It just refuses to load the page, instead displaying a page could not be loaded because of an invalid certificate error.

Demon Cleaner
10th December 2008, 16:51
Hm, weird. I'm still using v2, just got asked if I'd want to switch, but I refused again.

11th December 2008, 08:18
I've just been looking on the net and it appears to be an incompatability with old personal info and FF3. someone has found a solution.

the only way it working out is to remove (rename) personal info in Firefox (documents and settings) and do a complet reinstall. (you can use the Firefox addons (or even Mozilla backup tool) for your bookmarks & passw file to reinstall do this before you remove your old Firefox version, you need those files for import again.

Also if you have the errorzilla addon that can do a similar thing.

11th December 2008, 08:47
Thanks for finding that info. I will give that a try later when I have time. :thumbs:

11th December 2008, 09:51
Another problem can be if your system clock is incorrect it can give you the same error message even if you've added the page.

11th December 2008, 09:54
System clock is correct as it updates automatically from the internet. So I expect it is the other problem.